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2 Overview

The EVA5004 is especially designed to evaluate the PE5004 Capacitive Sensor Matrix Control IC of
Productivity Engineering GmbH featuring for very fast stimulating and reading of capacitive sensor
arrays and self capacitance sensors. A number of up to 100 sensors per chip can be selected by
user, multiple sensor arrays can be cascaded.

The EVA5004 serves as a demonstrator and evaluation kit with these features:

First PE5004 for board sensors

Second PE5004 for external user defined sensors

USB communication to PC per human protocol interface

2 x OLED from Novaled

uC CY7C64356 (firmware for EVA5004 board)

Display S64128K from Displaytech

8x7 Touch Matrix (extern 10x10)

Detailed representation of data in various windows on PC with graphical view
Save and load of presets

Evaluation Kit PE5004 v1.1
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3  Controlling software ,,EVA5004*
3.1 Installation

The software to control the EvaBoard a PC is a simple executable which don’t needs to be installed
separately, just run the actual downloadable version EVA5004_V2.x.exe

The EVA5004 comes with a graphical user interface for WindowsXP ™ platforms. It is recommended
to start with this simple software interface to learn about the basic functionality of the chip on the
board.

For the operation of the software the USB Human Interface Device (USB-HID) is required, these driver
is a part of for WindowsXP ™ platform.

For more precise display of graphs it is recommended to use the Windows XP-Design

(Control panel->View->Designs)

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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3.2 Software description — Connect EvaKit to USB device

After starting the software (over “Start” Menu) it is necessary to connect EvaBoard. For this action the
menu "File" - "Connect" or the icon should be used. After connection it is possible to disconnect the

EVABORD with the same buttons.

Select PE5S004 for

Open Touch Panel [Jraddle Game [ ]OLEDs (%) Board Sensors

Calibration ] [ Clear Calibration ]

() External Sensors

2 EVAS004KIT 2.0 M=
File Help
wed@ @
Main Control - Configuration Register 4
UPDATE Rate [ms] | [ Continous ] [ Stop ] [ Single ]
[ Dpen ¥alue Table ] [ Open ¥alue Grid ] [ Open Bar Graph ] Show Columin Nbr.

EYAS004 Connected via USE

ISO 9001 / 1SO 14001 \ 01/06/2016
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3.3 Software description — Main Control

The tab Main Control shows all functions to use the software and the EvaKit. The functions on these
tab manipulate the board directly and set showable frames with configured register. With load preset
on menu “File” > “Load Preset” or icon load preset it is possible to load self defined and saved
presets (“File”>"Save Preset” or icon save preset).

22 EVAS004KIT 2.0

File Help
wed@ ©
Main Control Configuration Register 4
UPDATE Rate [ms] J |5 | [ Continous ] [ Stop ] [ Single
[Dpenh‘alue Table ] [ Open ¥alue Grid ] [ Open Bar Graph ] Show Columin Nbr. ID:\__fl

Select PE5S004 for

Open Touch Panel [Jraddie Game [oLEDSs ® Board Sensors S E e G

Calibration ] [ Clear Calibration

Threshold :D I Stretch I1 | Filter I1

EYAS004 Connected via USE

Update Rate [ms] Slider, Text - Set the time between data transfer to PC in continuous mode

Continuous button - Start the sensoring cycle continuously on EvaBoard

Stop button - Stop sensoring mode on EvaBoard

Single button - Start the sensoring mode for one cycle

Open Value Table button - Open a window with value table

Open Value Grid button - Open a window with graphical display of value grid

Open Bar Graph button - Open a window with bar graph display for selected Column

Show Column Nbr coice - Select displayed column number in Bar Graph window

Open Touch Panel button - Open a window with touch points as display

Paddle Game check box - Select pin pong game on Touch Panel

OLED check box - Select the OLED sensors on EvaBoard

Select PE5004 radio box - Select the used PE5004 on EvaBoard for internal or external
sensors

All functions on used windows will be started with Single or Continuous button.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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Value Table uses 10 columns and 10 rows for External Sensors and 9 columns and 8 rows for Internal
Sensors (matrix field). Start and End rows/columns are also selectable. Column 1, 2 and row 0 are
used when OLEDs selected.

Value Grid. The calibration function and the invert check box shows various presentations.

B2 value Grid

Bar Graph shows bar graph of selected column

ROAD ROW1 ROW2 ROW3 R4 ROWS ROWE ROWY7 ROWE ROAT

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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Touch Panel with multitouch points. It is necessary to calibrate the board to use this Window.

Touch Panel with paddle game. It is necessary to calibrate the board to use this Window.

B - IE[X]

To play the game use the left and right vertical sensor line on EvaBoard (shift up and down) in
continuous mode.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /@ Productivity Engineering GmbH
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3.4 Software description — Main Control Calibration

The tab Main Control shows all functions to use the software and the EvakKit. Under a gray line the
calibration functions are defined. After a swap between OLEDs, Board Sensors and External Sensors,

the calibration should be carried out again.

22 EVASD04KIT 2.0

File Help

Led@ ©
Main Control Configuration Register 4
veoateRatetma] [(J———— j[5 | [ continous || stp J[ smge J
[Dpenh‘alue Table ] [ Open ¥alue Grid ] [ Open Bar Graph ] Show Column Nbr. |0+ |

Select PE5S004 for

Open Touch Panel [Jraddie Game [oLEDSs ® Board Sensors S E e G

Calibration ] [ Clear Calibration ]

Threshold iU Stretch |1 | Filter [1

EYAS004 Connected via USE

Calibration button - Start a self calibration function and set all necessary registers

- This is a white balance function for display in Touch Panel and

Value Grid

Clear Calibration button - Clear all variables of calibration for white balance
Threshold text - Set the threshold variable for Touch Panel and Value Grid
Stretch text - Set the stretch variable for Touch Panel and Value Grid
Filter text - Set an average for Touch Panel and Value Grid
ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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35 Software description — Configuration Register

To manipulate the configuration register of EvaBoard the tab "Configuration Register"” can be used.

= EVAS004KIT 2.0
File Help

New@

StartROV  StartCOL

@)

IMain Control Configuration Register

YaitROW x 10us ¥aitCOL x 10us

EoX)

[ v 1 ¥ |10 | s
EndROW  EndCOL PWRI

(& [ [« &

SINF

SINA U

pco
DACREF

GCo =0;

EYAS004 Connected via USB

StartRows choice
StartCol choice
EndRows choice
EndCol choice
WaitROW text

WaitCOL text

PWRI choice

SINF slide, text
SINA slide, text
PCO slide, text
DACREF slide, text
GCO slide, text

Search

ISO 9001 / ISO 14001 \

- Select the start number of used rows to sense

- Select the start number of used columns to sense

- Select the end number of used rows to sense (7 on EvaBoard)

- Select the end number of used columns to sense (8 on EvaBoard)

- Select the number of wait cycles between every row in 10us cycles

- Select the number of wait cycles between every column in 10u

cycles

- Select power mode of IU converter
- Frequency of sine generator in MHz

- Amplitude of sine generator in mV

- Phase shifter value

- Digital analog converter reference value

- Gain value of IU converter

- Auto search of best PCO value

01/06/2016
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4 Introduction of EVA5004 Hardware
Features PE5004:

e Suitable for two capacitive measurement styles:

- Sensing of small capacity changes in 10x10 mutual capacitance sensor arrays

- Sensing of self capacitance approximation and touch sensors

Controllable stimulation for wide spread of suitable sensor capacitance, layout and material
Highly sensitive, coatings of over 30mm for self capacitance sensors possible

Very low acquisition time of 15ms for 100 sensors in a matrix

High resolution of 10bit for each sensor

Sleep mode with programmable wake up intervals

Low operating current (< 3mA at max. speed)

Low-Power Mode for large Sensor shapes

Very low standby current during sleep (1pA)

Programmable Number of Sensors for optimal acquisition time and current consumption
No need for grounding of scanned object

No need for sampling capacitors or external resistors

High sensitivity to large parasitic capacitances

Very robust against noise

Temperature drift compensation

Multiple sensor arrays and PE5004 chips controllable with one pC:

Up to 700 sensors through [12C, up to 2000 sensors through SPI

41 PE5004 General Description

The PE5004 is a high precision capacitive sensing circuit which uses amplitude modulation for very
fast stimulating and reading of capacitive sensor arrays and self capacitance sensors. A number of up
to 100 sensors per chip can be selected by user, multiple sensor arrays can be cascaded. By
implementing a controllable sinusoidal generator with a wide range of frequencies and amplitude the
spectrum of suitable sensor capacitance is significantly increased for a large range of applications.
The implemented DAC with variable reference voltages guaranties proper function over varying
environmental conditions and provides digital controlled self calibrating capability. For low power
operation a sleep mode with ultra low standby current and programmable wake-up intervals is
implemented. Additionally Power consumption of internal Blocks can be programmed to a third of
normal if full 10bit-Resolution is not necessary or large Sensor shapes are used. By means of a
multimaster I2C interface several detector circuits can be controlled by one MCU.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
Page 11 of 18




EVA5004
User Guide SE RMA

PE5004 Evaluation Board PRODUCTIVITY ENGINEERING

5 Description of EvaBoard

The EVA5004 is especially designed to evaluate the PE5004 Capacitive Sensor Matrix Control IC of
Productivity Engineering GmbH featuring for very fast stimulating and reading of capacitive sensor
arrays and self capacitance sensors. The EvaBoard serves as a demonstrator and evaluation kit with
these features:

First PE5004 for board sensors

Second PE5004 for external user defined sensors

USB communication to PC per human protocol interface

2 x OLED from Novaled

uC CY7C64356 (firmware for EVA5004 board)

Display S64128K from Displaytech

10x10 Touch Matrix

Detailed representation of data in various windows on PC with graphical view
Save and load of presets

This board can be used as stand alone board with separate functions and a calibration over the GUI
software. Or it is usable fully with the GUI software with USB connection.

The structural description of the EvaBoard is shown in a separate file.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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6  Operation on GUI software
6.1 Using software for PC-EvaBoard interaction
Essentially steps to use the EvaBoard on PC:

e Connect the EvaBoard via USB on PC
- If this is the first connection a new USB-HID will be installed

e Start the software “EVA5004_V2.x.exe”

e Connect the EvaBoard with software
- Connect icon
- File > Connect

e Optional — load preset configuration
- Load icon
- File > Load Preset
- If no correct file is usable the default values will be loaded

Value Table usability:

Click button “Open Value Table”

Click “Continous” to start sensing

Touch on sensor matrix of EvaBoard

A “Calibration”, Threshold, Stretch and/or Filter variation show the functional effects on table
and displays variants of implementations

Value Grid usability:

Click button “Open Value Grid”

Click button “Calibration”

Click “Continous” to start sensing

Touch on sensor matrix of EvaBoard

Threshold, Stretch and/or Filter variation show the functional effects on table and displays

variants of implementations

e On tab “Configuration Registers” the sensitivity is controllable and is shown directly in
windows

e Optional: load “ConfigMatrix.txt”, all calibration and opening of needed Windows is done

automatic

Bar Graph usability:

Select number of “Shown Column Nbr.”

Click button “Open Bar Graph”

Click “Continous” to start sensing

Slide over selected column on sensor matrix of EvaBoard

A “Calibration”, Threshold, Stretch and/or Filter variation show the functional effects on table
and displays variants of implementations

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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Touch Panel usability:

Click button “Open Touch Panel”

Click button “Calibration”

Click “Continous” to start sensing

Touch on sensor matrix of EvaBoard, multitouch is possible

Threshold, Stretch and/or Filter variation show the functional effects on table and displays
variants of intensitations

e Optional: load “ConfigTouchDetection.txt”, all calibration and opening of needed Windows is
done automatic

Paddle Game usability:

Click button “Open Touch Panel”

Select “Paddle Game”

Click button “Calibration”

Click “Continous” to start sensing

Touch on sensor matrix of EvaBoard, left half for player 1, right half for player 2

Threshold, Stretch and/or Filter variation show the functional effects on table and displays
variants of intensitations

e Optional: load “ConfigPaddle.txt”, all calibration and opening of needed Windows is done
automatic

Stop and Single usability:

To stop sensing on EvaBoard click button “Stop”
A single sense is possible by touching the sensing matrix and click “Single”

Select PE5004 for usability:

e |f an external sensor is designed for the EvaBord (user specific definitions) it is possible to
switch to this option by selection of “external Sensors”. All internal sensor function are
deselected at this moment

e By default “Board Sensors” are selected

Save PES5004 Preset usability:

e After all configurations and probing of functions a saving of presets is possible
e Select “File” > “Save Preset” or click on icon save preset

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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6.2 Using software only for register calibration on EvaBoard
For a detailed configuration of internal PE5004 register the configuration function is possible.
Essentially steps to use the EvaBoard on PC:

e Connect the EvaBoard via USB on PC
- If this is the first connection a new USB-HID will be installed

e Start the software “EVA5004 _V10.exe”

e Connect the EvaBoard with software
- Connect icon
- File > Connect

e Optional — load preset configuration
- Load icon
- File > Load Preset
- If no correct file is usable the default values will be loaded

Configuration Register usability:
e Click on tab “Configuration Register”
e Select various register configurations via slider or text field and show results on EvaBoard
e Forthe PCO-register is automatically a good value to be set using the search button

Load PE5004 Preset usability:

e To use a predefined register configuration it is possible to load a saved preset
e Select “File” = “Load Preset” or click on icon load preset

Save PES5004 Preset usability:
e After all configurations and probing of functions a saving of presets is possible
e Select “File” > “Save Preset” or click on icon save preset

6.3 Using only EvaBoard

The GUI software is not necessary to use EvaBoard internal functions. The function of EvaBoard is
shown on display and is described in separate file.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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7  Configuring PE5004 for proper Sensor Readout

Software versions 2.3 and newer are preconfigured for use with the on board sensor matrix. After
every start of the software it is sufficient to open the Value Grid ore Value Table and press the
continuous button.

The PE5004 features a lock in amplifier, if the phase shift is not canceled (PCO Value) the sensing will
not work!

Therefore, if external Sensors are used the sliders in the “Configuration Register” tab must be
adjusted. It is also recommendable to try different settings with the on board matrix to get familiar with
the configurations and their impact on the sensor signal.

Important difference between On Board and external Sensors:

The GUI is designed to process full 10Bit Sensor data. The on board matrix is only read out with 8 Bit
as this is sufficient enough for the application. To prevent distortion in display of the data a “Stretch”
factor of 4 shall be used when not calibrated.

When using external Sensors full 10Bit Sensor data is transferred via USB. A Stretch factor of 1 leads
to natural resolution.

1. In “Main Control” choose continuous button and open “Value Grid”
(make sure that threshold is “0”, and stretch on “4” for board or “1” for external sensors)

2. Got to “Configuration Register” set SINF, SINA and DACREF to max, GCO to 4

3. Set StartROW, StartCOL, EndROW, EndCOL according to the sensor Layout, if you not shure
what values fit set all Startto 0 and all End to 9

4. Increasing PCO slider slowly starting from approx. 20 up to 300; there will appear a maximum
of the sensor grid at some point, this is the optimal value for phase shift canceling

5. If you exceed the maximum range ( whole grid is plain at the top or all values in “Value Table”
are at 1023) decrease SINA and start at Point 4. again.

If using very small sensor capacitances, the measured sensor Data can even with the correct PCO
value and with maximum SINF and SINA be very low. By decreasing the DACREF value the upper
reference voltage of the internal ADC is lowered, leading to a higher sensitivity but also to a higher
impact of noise. The minimum recommended DACREF value is 3, lower values may need more
settling time which makes it necessary to increase the WAITROW value.

ISO 9001 / 1ISO 14001 \ 01/06/2016 /© Productivity Engineering GmbH
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8 Notes
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9 Contact

Germany

Stuttgart Dresden

Productivity Engineering Productivity Engineering GmbH
Process Integration GmbH Branch

Behringstrasse 7 Sachsenallee 9

D-71083 Herrenberg D-01723 Kesselsdorf

Germany Germany

Phone.: +49 (0) 70322798 0 Phone.: +49 (0) 35204777 00
Fax: +49 (0) 70322798 29 Fax: +49 (0) 35204777 000
Email: info@pe-gmbh.com Email: info@pe-gmbh.com

Web: www.pe-gmbh.com

Quality data are available on request.

Important
Notice

All trademarks an

Productivity Engineering GmbH (PE) reserves the right to make corrections, modifications, enhancements,
improvements, and other changes to its products and services at any time and to discontinue any product or service
without notice. Customers should obtain the latest relevant information before placing orders and should verify that such
information is current and complete. All products are sold subject to PE’s terms and conditions of sale supplied at the
time of order acknowledgment. PE warrants performance of its hardware products to the specifications applicable at the
time of sale in accordance with PE’s standard warranty. Testing and other quality control techniques are used to the
extent PE deems necessary to support this warranty. Except where mandated by government requirements, testing of all
parameters of each product is not necessarily performed. PE assumes no liability for applications assistance or customer
product design. Customers are responsible for their products and applications using PE components. To minimize the
risks associated with customer products and applications, customers should provide adequate design and operating
safeguards. PE does not warrant or represent that any license, either express or implied, is granted under any PE patent
right, copyright, mask work right, or other PE intellectual property right relating to any combination, machine, or process
in which PE products or services are used. Information published by PE regarding third—party products or services does
not constitute a license from PE to use such products or services or a warranty or endorsement thereof. Use of such
information may require a license from a third party under the patents or other intellectual property of the third party, or a
license from PE under the patents or other intellectual property of PE. Resale of PE products or services with statements
different from or beyond the parameters stated by PE for that product or service voids all express and any implied
warranties for the associated PE product or service and is an unfair and deceptive business practice. PE is not
responsible or liable for any such statements.

© 2016 PE GmbH. All rights reserved.

d registered trademarks are the property of their respective owners.
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